Get in touch
Back
Downtime

Degraded performance

Started 4 Oct at 02:42pm EDT, resolved 4 Oct at 02:48pm EDT.

App Server
Resolved

We've fixed the issue for now and will investigate the root cause.

Posted 4 Oct at 02:48pm EDT.
Updated

Services are recovering

Posted 4 Oct at 02:47pm EDT.
Created

Devices may reboot or display the Tidbyt logo. We are troubleshooting.

Posted 4 Oct at 02:42pm EDT.